RSS

Firefox 4 sul eeepc

9 aprile 2011

Firefox, Xandros

firefox-64

Per chi usa la Xandros sul portatilino, vista la non possiblitià di aggiornare il sistema, si è  dovuto faticare per poter avere Firefox 3 funzionante, coi problemi di libreria GTK. Con l’usicta di Firefox 4, la situazione si aggrava, dato che ora è interessata la libreria standard glibc.

In questo caso il problema riguarda anche altre distribuzione con supporto a lungo termine, come la CentoOS, ed è proprio grazia ad un pacchetto rpm che si riuscirà a far funzionare Firefox 4.

Per semplicità ho scompattato l’RPM e fatto in modo che lo script automatico si arrangi per far tutto. Lo script è questo:

#!/bin/sh
echo Installazione automatizzate di Firefox 4 su Xandros -ver 0.1
echo nelle versioni senza GTK2 installata
echo Creazione della directory /opt/firefox4
mkdir /opt/firefox4
echo Modifica dei permessi sulla direcoty /opt/firefox4
chmod 777 /opt/firefox4
echo Spostamento sulla directory temoporanea
cd /tmp
echo Download di Firefox 4
wget -c http://ftp.sunet.se/pub/www/clients/mozilla.org/firefox/releases/4.0/linux-i686/it/firefox-4.0.tar.bz2
wget -c http://ftp.uni-kl.de/pub/mozilla/firefox/releases/4.0/linux-i686/it/firefox-4.0.tar.bz2
echo Estrazione di Firefox sulla temp
tar -jxf firefox-4.0.tar.bz2 --overwrite
echo Entro nella directory di Firefox
cd firefox
echo Copia i file di firefox su /opt/firefox4
cp -r * /opt/firefox4
echo Si ritorna sulla temp
cd /tmp
echo Scarico della libreria gtk2
wget -c http://download.tuxfamily.org/xepcrepo/pool-main/gtk-2.10/libgtk2.0-0_2.10.13-2~bpo.1_i386.deb
echo Crea la cartella /opt/gtk2
mkdir /opt/gtk2
echo Modifica i permessi della cartella
chmod 777 /opt/gtk2
echo Entra su /opt
cd /opt
echo Installa la libreria gtk2
dpkg-deb -x /tmp/libgtk2.0-0_2.10.13-2~bpo.1_i386.deb gtk2
echo Si ritorna sulla temp
cd /tmp
echo Scarica la libreria libc
wget -c http://eeepc901.altervista.org/download/libc.tgz
echo Scompatta la libreria
tar -xzf libc.tgz
echo sposta i files
mv libstdc++.so.6* /opt/firefox4

e lo potete scaricare da qui: http://eeepc901.altervista.org/download/install_firefox4.tar.gz

Lo script agirà come per la versione 3.6 ed in più copierà 2 files (uno regolare e un link simbolico) nella cartella di Firefox 4, permettendo così di funzionare.

Ricordo di lanciare lo script come super utente, aprendo una finestra bash in questo modo:

sudo bash

Dopo l’installazione, se avete problemi con le librerie GTK vi basta operare come in Firefox 3.6 ricordando che ora l’installazione è avvenuta dentro /opt/firefox4 e pertanto per eseguire il nuovo Firefox dovete usare /opt/firefox4/firefox

Buona navigazione 😉

 

 

 

 

,

57 Responses to “Firefox 4 sul eeepc”

  1. Maxx Says:

    Posso riformulare le domenda di pippo … Ma come si fa ad andare appresso a una distribuzione in questo modo? 🙂

    Io ho Ubuntu sul mio EEEPC 900 e non ho avuto problemi con Firefox 4, non mi sembra che Xandros sia così bella da valere tutta questa fatica …

    Grazie comunque ho linkato questa pagina per chi mi chiede riguardo a Xandros.

  2. ice00 Says:

    >Io ho Ubuntu sul mio EEEPC 900 e non ho avuto problemi con Firefox 4, non mi sembra che Xandros sia così bella da valere tutta questa fatica …
    Sul 900 ci sono già le librerie libc aggiornate, per cui li non c’è problema per Firefox 4 😉

    Per la Xandros, non tutti sono in grado di installarsi una distribuzione nuova sul PC (non parlo solo di Linux, il cui installer è ormai molto più evoluto e semplice della controparte Windows, ma anche di Windows stesso), pertanto preferiscono tenere il sistema che hanno già, se riescie a stare al passo coi programmi che servono loro.

    >Ok,grazie aspetto tue notizie.
    Ho approffitato del weekend lungo per aggiornare il sistema da Fedora 14 a 15, pertanto finchè non completo la procedura al 100%, non installo le librerie a 32 bit per tentare il link statico del programma.

  3. ice00 Says:

    Riscarica il pacchetto e riprova ora. H oisnerito due versioni linkate staticamente del programma di patch

  4. Christian Says:

    Ciao e grazie volevo dirti che anche stavolta niente da fare,ho provato tutti e 2 i file e questa volta l’errore che mi da è questo:

    FATAL: kernel too old
    Segmentation fault

    Incomincio davvero a disperarmi e a pensare che non potrò mai avere firefox 4 🙁 🙁

  5. ice00 Says:

    Purtroppo le librerie statiche cercano qualche aggancio al kernel che non trovano 🙁

    Vedo di mandarti per mail i files già patchati (però sarà una mail di più di 5MB) di Firefox da provare direttamente.

  6. Christian Says:

    ok,la mia mail è [hidden],grazie ancora.

  7. Grazie per il post, adoro Firefox Says:

    Grazie mille per il post, Firefox is the best 🙂

Leave a Reply