Crea sito
RSS

Installazione del plugin Flash Player su Xandros

12 Settembre 2010

Firefox, Xandros

flash-64

Per chi ha installato Firefox su Xandros seguendo le istruzioni precedenti e volesse installare anche il plugin per Flash Player, basta che segua le seguenti instruzioni.

Per prima cosa serve scaricare la versione .tar.gz per Linux dal sito di Adobe, che contiene un unico file: una volta estratto, va posto sulla directory dei plugin di Firefox.

L’operazione può essere agevolmente eseguita da console, tramite questi comandi:

sudo bash
cd /tmp
wget -c http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
tar -xzf install_flash_player_10_linux.tar.gz
cp ./libflashplayer.so /opt/firefox3/plugins/

Ora basta avviare Firefox e verificare che il plugin compaia correttamente nell’elenco sulla pagina about:plugins.

La versione (appena scaricata) segnala un Shockwave Flash ver 10.1 r82

Nel caso otteniate un valore inferiore, cercate su tutto il vostro disco della presenza di questo file: libflashplayer.so
E’ probabile infatti che questo file venga prioritariamente caricato da Firefox rispetto a quello installato nella directory che abbiamo usato noi!

,

38 Responses to “Installazione del plugin Flash Player su Xandros”

  1. Gian Says:

    Ciao,
    ho seguito tutti i tuoi passi per installare la versione ultima di firefox e tutto funziona OK, solo con il plugin di FLASH, mi sta dando qualche problema… nonostante io segua tutti i passi indicati sopra, quando io faccio about:plugins non compare nell’elenco…

    …ho rinominato quello all’interno di /opt/firefox/plugins

    ….ho provato a cercare altri file

    sudo find / -name libflashplayer.so

    e ne ho travato uno anche dentro
    /usr/lib/mozilla/plugins

    e ne ho trovato anche

  2. ice00 Says:

    Non ti appare nessun plugin di flash o ce n’è uno della versione errata?

  3. Gian Says:

    Non mi compare nessun plugin…. è come se non ci fosse proprio!

    Per elenco io intendo dando il comando

    about:plugins

    però se provo a guardare un video su youtube, in alto mi compare la barra che mi informa che il programma ha bisogno di un plugin mancante, e compare la richiesta di installazione automatica che però non funziona….

    nello spazio del video compare quel simboletooo che sembra un pezzo di puzzle, che mi dice che il plugin è andato in errore..

    allora non capisco se c’è e non funziona oppure non c’è proprio…

    grazie mille

  4. ice00 Says:

    Avevi rinominato tutti i libflashplayer.so trovati sul disco non nella posizione in cui hai salvato quello scricato?

    Mi sembra strano che il plugin dia errore di esecuzione (che col nuovo Firefox non va più in crash, ma da un avviso), ma non appaia sull’elenco dei plugins installati

  5. giusca Says:

    ciao ice, volevo chiederti se è possibile installare il plugin di microsoft silverlight… non riesco a vedere alcuni video… grazie in anticipo

  6. ice00 Says:

    Tempo fa lo avevo installato sul pc fisso quando c’era ancora Firefox 3.0.x, quindi non dovrebbero esserci problemi, però nel weekend faccio le prove sul netbook e poi posto i risultati e la procedura 😉

  7. Beppe Says:

    il problema è che il plugin flash necessita delle GLIBC_2.4, infatta lanciando firefox da shell:

    (Gecko:17223): Gtk-WARNING **: Impossibile trovare il gestore dei temi in module_path: «clearlooks»,
    LoadPlugin: failed to initialize shared library libXt.so [libXt.so: cannot open shared object file: No such file or directory]
    LoadPlugin: failed to initialize shared library libXext.so [libXext.so: cannot open shared object file: No such file or directory]
    LoadPlugin: failed to initialize shared library /opt/firefox3/plugins/libflashplayer.so [/lib/tls/libc.so.6: version `GLIBC_2.4′ not found (required by /opt/firefox3/plugins/libflashplayer.so)]

    come si può fare?

  8. ice00 Says:

    Prova a cercare dove di trova la libreria libc.so sul tuo computer.
    Se siamo fortunati forse è solo che flash cerca la libreria su questo percorso (/lib/tls/libc.so.6), invece che in quello in cui si trova nel sistema.

  9. beppe Says:

    niente fortuna…la libreria c’è eccome….ma la versione è 2.3.6…

  10. ice00 Says:

    Allora vedo un pò problematica la cosa, perchè se hai una glibc 2.3.6 bisogna aggiornare il sistema per avere la 2.4, perchè è la libreria cardine e quasi tutti i programmi fanno riferimento ad essa.

    Devo vedere se è possibile averne una installata in un altra posizione e far puntare solo Firefox e Flash su tale glib..

  11. Christian Says:

    Ciao,alla fine sono riuscito ad aggiornare firefox e mi parte benissimo,ma adesso mi sono arenato su flash player,ho seguito tutte le istruzioni e alla fine mi da “si è verificato un arresto anomalo del plugin adobe flash,che devo fare,help me please!!!

  12. ice00 Says:

    Controlla su
    about:plugins
    la versione di flash player installata (che deve essere l’ultima e non una precedente che magari si trova nel sistema).

    Il flash una volta su 10 va in crash anche a me durante la navigazione su di un sistema a 64 bit, se invece ti succede sistematicamente la cosa sembra più grave.

  13. souther Says:

    Ciao, dopo molto tempo sono di nuovo alle prese con l’Eee pc. Avendo già installato l’ultima versione disbonibile per Xandros, sto cercando di installare anche il plugin flash player, ma usando la prima parte dei comandi descritti, dopo aver digitato la terza righa, il terminale mi dà “ERRORE 404 Not Found”
    Puoi darmi un aiuto a risolvere?

  14. ice00 Says:

    Ciao,
    è molto probabile che con le nuove versioni del flash, abbiano cambiato il link al download.
    Cerco il nuovo percorso e te lo comunico

  15. souther Says:

    grazie, resto in attesa allora

  16. ice00 Says:

    In effetti hanno reso il ramo 11 la versione stabile, pertanto il link alla 10 non era più valido.

    Ecco le istruzioni aggiornate per estrarre la libreria:

    sudo bash
    cd /tmp
    wget -c http://fpdownload.macromedia.com/get/flashplayer/pdc/11.1.102.55/install_flash_player_11_linux.i386.tar.gz
    tar -xzf install_flash_player_11_linux.i386.tar.gz
    cp ./libflashplayer.so /opt/firefox3/plugins/

  17. souther Says:

    Il file adesso viene scaricato e salvato, subito dopo ho immesso la quarta riga ma non succede nulla.. e il browser segnala sempre un arresto anomalo del plugin

  18. ice00 Says:

    Verifica su about:plugins di Firefox se la versione che vede adesso del flash sia la 11. Se da errore sospetto che questo sia compilato con librerie non più adeguate alla xandros.

    La 4° riga è per copiare la libreria sulla posizione che Firefox si aspetta di trovarla.

  19. souther Says:

    Dunque ho controllato andando su Strumenti/Componenti Aggiuntivi e tra i plugins di Adobe figura la versione 7.0. Invece nel percorso /opt/firefox3/plugins ci sono 2 files: libflashplayer.so e libnullplugin.so. Io credo di avere la versione più vecchia di Xandros…

  20. ice00 Says:

    Versione 7 è vecchissima, quindi sembra che non legga la nuova.
    Che versione di Firefox usi?

  21. souther Says:

    Uso la 3.6.6, che ho installato seguendo la tua guida circa un anno fa. Ho letto che la 4 e la 5 non sono compatibili con le versioni più vecchie di Xandros, quindi non ho provato neanche ad installarle. Il fatto è che senza il flash player aggiornato la navigazione risulta davvero frustrante..

  22. ice00 Says:

    Penso che l’unica si trovare un pacchetto di Flash in versione 10. Non sarà aggiornato, ma forse c’è qualche speranza in più di successo. Cerco di trovarla e posto il link.

  23. ice00 Says:

    E’ strano però che ti esca la versione 7.
    Cerca dove si trovano sul filesystem, tutti i files di nome ibflashplayer.so, perchè forse ce n’è uno che bypassa quello su /opt/firefox3

  24. Cle Says:

    Buongiorno a tutti,
    parto subito ringraziando ice00 per il lavoro fatto e per la chiarezza di queste guide.
    Ora cerco di spiegare quale è il mio problema: seguendo le guide qui proposte sono riuscito ad installare firefox 3.6, senza però riuscire a utilizzare un flash player decente, infatti mi rimanda a flash player 9 ogni volta che apro ff. Il flash player che ho installato (senza successo) è il numero 11. Ringrazio anticipatamente per l’attenzione!
    P.S: penso che souther abbia fatto un mio stesso errore iniziale, cioè guardare sugli strumenti il flash player, però quello è adobe reader! Infatti per guardare la versione di fp bisogna andare sulla barra dove si scrive http:// ecc, cancellare e scrivere about:plugins e poi verificare il numero della versione.
    Grazie ancora, arrivederci.

  25. ice00 Says:

    ciao, in effetti temo che solo trovando la versione 10 si riesca a far funzionare il flash player sulla prima Xandros, perchè la 11 userà le librerie glibc aggiornate (come gli ultimi firefox).

    La sto ancora cercando…

  26. souther Says:

    Mi scuso per il ritardo, ho digitato About:Plugins, ed esce fuori questo:

    Default Plugin

    File: libnullplugin.so
    Versione: 1.0.0.15
    The default plugin handles plugin data for mimetypes and extensions that are not specified and facilitates downloading of new plugins.
    Tipo MIME Descrizione Estensione Attivo
    * All types .* No

    Ok, se riesci a trovare la versione 10 ci posso riprovare, anche se ormai temo di dover navigare con il portatilino solo a tempo determinato, vista anche l’impossibilità di aggiornare il browser. Anche perchè la mia è proprio la versione 700 dellì eeepc, quella con soli 2 gb di memoria, quindi avrei anche difficoltà ad installare sistemi operativi più versatili. Comunque grazie per il disturbo

  27. ice00 Says:

    La versione 10 si trova per tutte le piattaforme inquesto file zip:

    http://fpdownload.macromedia.com/get/flashplayer/installers/archive/fp10.1_archive.zip

    da qui va presa la versione linux flashplayer_10_1r82_76_linux.tar.gz e posta sotto /tmp, quidi poi

    sudo bash
    cd /tmp
    tar -xzf flashplayer_10_1r82_76_linux.tar.gz
    cp ./libflashplayer.so /opt/firefox3/plugins/

  28. Cle Says:

    Chiedo ancora scusa, ma purtroppo non funziona… Mi dice che le glibc_2.4 non si trovano… Ho letto cio che e scritto sopra, percio ti chiedo se e possibile aggiornare queste librerie in maniera piu o meno semplice.
    Grazie mille

  29. ice00 Says:

    Il problema di questa libreria è quello che non permette di passare all’ultimo firefox sulla prima xandros e, dato che glibc è la libreria da cui dipendono tutti i programmi installati, per aggiornare essa, bisogna avere tutto il sistema convertito, cosa che non è possibile a meno di non cambiare distribuzione.

    Forse l’alternativa più percorribile (senza piallare la xandros) sarebbe quella di usare una distribuzione leggera come puppy (oppure adirittura Android per eeepc) da pen drive configurata a tutto punto per navigare e usarla in dual boot.

    Ovviamente la scelta a lungo termine più performante sarebbe adottare una nuova distribuzione, in modo da avere tutto il sistema aggiornato e veloce.

  30. Cle Says:

    Ok, credo di aver capito, ti ringrazio infinitamente per la pazienza e la disponibilita’ dimostrata.
    Ciao ciao

  31. souther Says:

    Non ho ancora avuto modo di provare ad installare la versione 10 del flash, nel frattempo volevo chiederti cosa mi consiglieresti come alternativa a Xandros sull’Eee 700. EasyPeasy sembra interessante..

  32. ice00 Says:

    Dreri che la EasyPeasy è una delle distro tollamente orientale al Netbook per cui è una delle scelte ottime per il modello 700. Tra l’altro deve essere appena uscita la versione 2.0-alpha da pochi giorni, mentre la 1.6 è ferma a fine 2010.

    Io ho anche un occhio di riguardo anche per Bodhi Linux, dato che utilizza Enlightenment come desktop manager che è leggero ma comunque molto interessante.

    Le altre distribuzioni maggiorni di default superano di molto i 2GB di installazione perciò per il 700 può essere più problematico da gestirle.

  33. souther Says:

    La 1.6 viene quindi ancora supportata? O anche in quel caso ci sarebbero problemi di aggiornamento?

  34. ice00 Says:

    Easy Peasy 1.6 è basata su Ubuntu 10.04 i cui aggiornamenti temineranno ad Aprile 2013. Dopo quella data sicuramente anche Easy Peasy non riceverà più aggiornamenti.

  35. souther Says:

    Capito. Un’altra cosa: sai se è possibile installare Unetbootin su Xandros? E’ un file di tipo .BIN

  36. ice00 Says:

    Si tratta di un file esegibile che trovi pacchettizzato in vari formati (deb, rpm) e anche in file eseguibile direttamente.
    I vincoli che vedo è che se risultasse compilato con una glibc recente, lanciandolo sulla Xandros ti darebbe gli errori come per Firefox, oppure se la gtk usata per la schermata grafica di Unetbootin fosse troppo recente anche in questo caso potrebbe non partire.

    In ogni caso trovi l’ultimo eseguibule qui:
    http://sourceforge.net/projects/unetbootin/files/UNetbootin/568/unetbootin-linux-568/download

    ti basta renderlo eseguibile cambiandone i permessi una vlta che lo hai copiato e poi lo esegui da console

  37. kiki Says:

    Ehi ciao..oggi stavo x giocare con un gioco di facebook e mi è spuntata una finestra grigia con un tassello del puzzle con scritto “impossibile caricare plug-in” la stessa cosa succede in tutti i giochi…che posso fare x risolvere il problema??

  38. ice00 Says:

    ciao,
    che eeepc hai? perchè sulla prima versione di Xandros ormai non si può più avere i componenti aggiornati 🙁

Leave a Reply